Accessing custom worlds after re-imaging


#1

Hi,

I’m having trouble accessing saved creative mode worlds after doing a rebuild.

I created a new v2.02 image on a new SD card after the original failed. I’ve copied my old custom worlds into /home/pi/piper/game/levels/userWorlds/minecraftWorlds, and I can see these as planets and click on each of them.

However, the ‘Creative Mode’ button is greyed out and not clickable, so I can’t open these worlds. I’ve also created a new custom world in the game, made some edits and saved, however I can’t re-open these worlds either. Similarly, the button is greyed out and not clickable for Hogwarts etc .

I updated unlockedLevels.txt and highestLevelPlayed.txt to 9. I also updated the levelsCompleted.txt with a ‘1’ against each level I had completed in the old build.

Can you please advise how I can get creative mode working please?

Many thanks!


#2

Hi @miscott,

Have you tried setting ALL of the levels in levelsCompleted.txt with a ‘1’? I see a similar issue if I reset player data (via the options menu), but the “creative mode” button becomes un-greyed out (or clickable) after assigning the first 8 levels a ‘1’ in levelsCompleted.txt.

Thanks and please keep us posted!

  • Jordan